Menu
Кошик

Русский военный корабль, иди нахуй!

Sloth Dev не предоставляет техническую поддержку клиентам и проектам, которые как-либо связаны с РФ или РБ. Любые запросы техподдержки будут проигнорированы. Ищи своих. Слава Україні!

Знижка для розробників з України

Колеги з України, для вас діє безстрокова акція - знижка 50% на всі модулі. Поширюється на всі модулі, обмеження на кількість ліцензій нема. Знижка сумується з діючими акціями.
Код знижки: PUTINHUILO
Слава Україні!

Мультимовні налаштування

Мультимовні налаштування
Мультимовні налаштування
Мультимовні налаштування
Мультимовні налаштування
Мультимовні налаштування
Мультимовні налаштування
Мультимовні налаштування
Мультимовні налаштування
Мультимовні налаштування
Мультимовні налаштування
Мультимовні налаштування
Мультимовні налаштування
Мультимовні налаштування
3.x 2.x 1.x
Мультимовні налаштування
Мультимовні налаштування
Мультимовні налаштування
Мультимовні налаштування
Мультимовні налаштування
Ще 8

Опис

За замовчуванням, налаштування опенкарт не підтримують багатомовність. Це стає проблемою при використанні кількох мов на сайті, адже необхідно вказати багато важливої інформації різними мовами: SEO-дані, контакти, а часто й логотип.
Модуль Opencart Мультимовні Налаштування допоможе вирішити цю проблему.

Нова версія 3.0, в порівнянні з попередніми версіями, має абсолютно інший підхід до реалізації багатомовності налаштувань опенкарт. Багатомовні Налаштування 3.0 – це окремий модуль з мінімальним втручанням в систему.

Важливо! Мультимовні Налаштування 3.0 підтримують лише Opencart 2.3 та Opencart 3.0.x.

Які поля модуль допоможе зробити багатомовними:

  • Мета-тег Title
  • Мета-тег 'Description'
  • Мета-тег 'Keywords'
  • Назва магазину
  • Власник магазину
  • Адреса магазину
  • Geocode
  • E-Mail
  • Телефон
  • Факс
  • Зображення
  • Режим роботи
  • Додаткова інформація
  • Логотип магазину

При установці модуль автоматично скопіює існуючі значення полів. Модуль підтримує мультимагазин.
 

Опис для старих версій

Мультимовні налаштування - це OCMOD-доповнення для Опенкарт 3.x, 2.x, 1.5.x, яке робить деякі поля у налаштуваннях Опенкарт багатомовними. 

Тепер підтримується Опенкарт 3.x

Підтримувані поля:

  • Мета-тег Title
  • Мета-тег 'Description'
  • Мета-тег 'Keywords'
  • Назва магазину
  • Власник магазину
  • Адреса магазину
  • Geocode
  • E-Mail
  • Телефон
  • Факс
  • Режим роботи
  • Додаткова інформація

Крім того, поле Телефон збільшено до 64 символів.

Увага! Змінюється формат зберігання даних (з рядка на серіалізований масив), тому в сторонніх модулях, які використовують зазначені вище поля, може виникнути помилка Array to string conversion. Якщо Ви отримали таку помилку, зверніться до нас - додамо підтримку потрібних модулів.


Історія версій

3.0 (18.03.2021)

Базовий код модуля створено у Генераторі Модулів Опенкарт.

Що нового Мультимовних Налаштуваннях 3.0:

  • модуль отримав власний інтерфейс налаштувань;
  • абсолютно інший алгоритм роботи, завдяки якому сумісність з іншими доповненнями має бути значно вищою;
  • втручання в код опенкарт - мінімальні. В новій версії немає великого і складного модифікатора;
  • додано підтримку полів Зображення та Логотип магазину;
  • версія 3.0 підтримує тільки опенкарт 2.3 та опенкарт 3.0.х.


Як оновитися, якщо у вас встановлена стара версія Мультимовних Налаштувань:

  1. Встановити модуль за допомогою інсталятора опенкарт.
  2. Увімкнути та налаштувати модуль. При першому включенні модуль скопіює існуючі налаштування.
  3. Перейти до списку модифікаторів та відключити стару версію. Якщо модифікатор було встановлено у папку /system - видалити його або перейменувати.
  4. Оновити кеш модифікаторів.
  5. Очистити кеш теми (для опенкарт 3).

Відгуки

Написати відгук

Примітка: HTML розмітка не підтримується! Використовуйте звичайний текст.
Погано Добре
Captcha
Мультимовні налаштування
354.65 грн

Доступні варіанти

Купити
Не змінює та не перезаписує файли
Не потребує IonCube Loader
Чистий та зрозумілий код
Необмежена підтримка
Демо
Адмінкаdemo.helpforsite.com/3032/admin
Логін: demo
Пароль: demo
Вимоги
Версія PHP5.4+
OCMOD (тільки ОС 2)Багаторядковий пошук в OCMOD
OCMOD: виправлення обробки error="skip"
vQmod (тільки ОС 1.5)2.5+
Сумісність
Версія OpenCart1.5.x, 2.x, 3.0.x
Інше
Мова інтерфейсуUA, EN, RU